Custom Axes issue

TeeChart FireMonkey (Windows,OSX,iOS & Android) for Embarcadero RAD Studio, Delphi and C++ Builder (XE5+)

Custom Axes issue

Postby Peter Carr » Sun Jul 16, 2017 5:35 pm

To reproduce the issue, add a TChart to a FMX Multi-Device Application and insert the code below into the implementation section.

The code below adds two custom tick marks and labels to the TChart bottom axis and sets the axis labels to be large and red. It works fine in Delphi 10.1 Berlin with Teechart Pro v2017.21.170329 32 bit FMX. It does not work in Delphi 10.2 Tokyo with Teechart Pro v2017.22.170619 32 bit FMX, where the custom labels appear at default size and in black.

Is this a bug or am I doing something wrong. If a bug, is there a workaround until you fix it?

Code: Select all
uses
  FMXTee.Series, System.UIConsts;

procedure TForm3.FormCreate(Sender: TObject);
begin
  Chart1.View3D := False;
  Chart1.Axes.Bottom.SetMinMax(1, 10);
  Chart1.Axes.Bottom.Items.Add(2, '2');
  Chart1.BottomAxis.Items.Add(5, '5');
  // Make bottom axis tick labels big and red
  Chart1.BottomAxis.LabelsFont.Size := 30;
  Chart1.BottomAxis.LabelsFont.Color := claRed;
end;
Peter Carr
Newbie
Newbie
 
Posts: 5
Joined: Tue Nov 08, 2016 12:00 am

Re: Custom Axes issue

Postby Christopher » Mon Jul 17, 2017 1:28 pm

Hello,

Many thanks for reporting this issue to us - it is a defect which I have added to our issue-tracking database with id=1894. At the moment I cannot suggest a workaround for you, but if I discover one in the near future I will certainly pass it on to you.
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum
Christopher
Advanced
 
Posts: 950
Joined: Fri Nov 15, 2002 12:00 am

Re: Custom Axes issue

Postby Peter Carr » Wed Aug 09, 2017 6:58 am

As a workaround, I have reverted to using the v2017.21 Teechart in Delphi 10.2 Tokyo. In other words, I am skipping v2017.22 due to this bug.
Peter Carr
Newbie
Newbie
 
Posts: 5
Joined: Tue Nov 08, 2016 12:00 am

Re: Custom Axes issue

Postby Sandra » Wed Aug 09, 2017 9:51 am

Hello Peter,

Many thanks for the information. I have added the information to the bug id=1894.

Thanks in advance
Best Regards,

Sandra Pazos / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Image Image Image Image Image Image
Instructions - How to post in this forum
Sandra
Site Admin
Site Admin
 
Posts: 3081
Joined: Fri Nov 07, 2008 12:00 am


Return to FMX

Who is online

Users browsing this forum: No registered users and 2 guests