IntraWeb + VCL

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.

IntraWeb + VCL

Postby Ralf1603 » Fri Feb 16, 2018 10:51 am

Hello,

I would like to use a TDBChart variant with IntraWeb (Datasource: TADODataSet component). However, the appropriate Steema / Intraweb components are missing.

My environment:
- Embarcadero C++ Builder 10.1 Berlin Update 2 Ent
- IntraWeb version: 14.2.6 (IntraWeb Bundled Edition for RAD Studio XE3-10.2 Ent/Arch), recommended, free update of Atozed Software
- Win 7 SP1 Ent

https://www.steema.com/downloads/vcl:
... Additional downloads, Integration for IntraWeb
Old Version: TeeChart Standard 2013 for IntraWeb 14.0 in Delphi XE4 (September 09, 2013)

I think the design time / run time packages need it (*.bpl) for C++Builder.
Can you help?

Regards, Ralf
Ralf1603
Newbie
Newbie
 
Posts: 3
Joined: Wed Feb 07, 2018 12:00 am

Re: IntraWeb + VCL

Postby Yeray » Fri Feb 23, 2018 9:18 am

Hello,

I've just added to the list the zip containing the sources for the integration of TeeChart into Intraweb 14 for RAD Studio 10.1 Berlin.
Could you please give it a try?
Best Regards,

ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image ImagePlease read our Bug Fixing Policy
Yeray
Site Admin
Site Admin
 
Posts: 8434
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia

Re: IntraWeb + VCL

Postby Ralf1603 » Wed Mar 07, 2018 8:15 am

Hello Yeray,

unfortunately there are problems. I am using the latest update recommended by Atozed Software on IntraWeb to 14.2.x (https://www.atozed.com/category/iw/iw-release/), the original Bundled version 14.0 had to be uninstalled.
Does the version supplied by Embarcadero have to be used?
~~~
Target _PasCoreCompile:
c:\program files (x86)\embarcadero\studio\18.0\bin\dcc32.exe -$O- -$W+ --no-config -B -Q -TX.bpl -
[...]
C:\Users\[user]\Documents\Embarcadero\Studio\Projekte\TeeChart_2017_for_IntraWeb_14.0_and_RADStudio_XE10.1_Berlin_Std\IW140TeeChart9_240.dpk(39,10): error F2202: E2202 Package 'Intraweb' wird benötigt, konnte aber nicht gefunden werden
Done building target "_PasCoreCompile" in project "IW140TeeChart9_240.dproj" -- FAILED.
Done building project "IW140TeeChart9_240.dproj" -- FAILED.

Best Regards,
Ralf
Ralf1603
Newbie
Newbie
 
Posts: 3
Joined: Wed Feb 07, 2018 12:00 am

Re: IntraWeb + VCL

Postby Yeray » Wed Mar 07, 2018 11:13 am

Hello,

Ralf1603 wrote:I am using the latest update recommended by Atozed Software on IntraWeb to 14.2.x (https://www.atozed.com/category/iw/iw-release/), the original Bundled version 14.0 had to be uninstalled.

I've just installed v14.2.7 and the packages seem to compile fine with TeeChart Pro v2017.23 installed.
I only had to modify an entry in the requires section in the IW140TeeChart9_240.dpk file, from "Tee" to "Tee924". If you use the TeeChart Standard/Lite shipped with the IDE, the packages should work without this change.

What TeeChart version do you have installed?
Best Regards,

ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image ImagePlease read our Bug Fixing Policy
Yeray
Site Admin
Site Admin
 
Posts: 8434
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia

Re: IntraWeb + VCL

Postby Ralf1603 » Fri Mar 09, 2018 2:38 pm

Hello Yeray,

I've installed IntraWeb v14.2.7 and now TeeChart Pro v2017.23 installed, modify "IW140TeeChart9_240.dpk".

Loaded in IDE "TeeChart Std 2017 for Intraweb 14 and RADStudio XE 10.1 Berlin.groupproj"
[dcc32 Fataler Fehler] IW140TeeChart9_240.dpk(39): E2202 Package 'Intraweb' wird benötigt, konnte aber nicht gefunden werden
...
requires
rtl,
vcl,
vclx,
inet,
vclimg,
Tee924,
Intraweb;
...

[dcc32 Fataler Fehler] DCLIW140TeeChart9_240.dpk(35): E2202 Package 'Tee' wird benötigt, konnte aber nicht gefunden werden
...
requires
rtl,
designide,
IW140TeeChart9_240;
...

Thanks for the support.

Best regards,
Ralf
Ralf1603
Newbie
Newbie
 
Posts: 3
Joined: Wed Feb 07, 2018 12:00 am

Re: IntraWeb + VCL

Postby Yeray » Tue Mar 20, 2018 8:52 am

Hello Ralf,

It seems the "Intraweb" and "Tee" packages can't be found. Please try to modify the requires list matching the packages (bpls) you have installed.
In IW140TeeChart9_240.dpk, try replacing "Intraweb" by "Intraweb_14_D10_1"
Best Regards,

ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image ImagePlease read our Bug Fixing Policy
Yeray
Site Admin
Site Admin
 
Posts: 8434
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia


Return to VCL

Who is online

Users browsing this forum: No registered users and 5 guests