Working *.exe with release configuration in Delphi 10.3

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
cormier
Newbie
Newbie
Posts: 3
Joined: Mon Feb 28, 2022 12:00 am

Working *.exe with release configuration in Delphi 10.3

Post by cormier » Thu Mar 17, 2022 4:58 pm

Hello,

As I hav'nt got any answer to my post of 11-03-2022, I try again :

My configuration :
- Win10 64,
- TeeChart 2022.34 with source, licenced,
- Delphi 10.3.1.

The issue :
- The *.exe obtained when compiling in debug mode work fine,
- but the *.exe obtained when compiling in release configuration don't work at all.

I don't know if it is because of my configuration/installation of Delphi/TeeChart, or if it is a licence limitation.

=> Does anybody can give me some light ?

Thank's in advance

remi cormier

Marc
Site Admin
Site Admin
Posts: 1086
Joined: Thu Oct 16, 2003 4:00 am
Location: Girona
Contact:

Re: Working *.exe with release configuration in Delphi 10.3

Post by Marc » Tue Mar 22, 2022 9:42 am

Hello Remi,

Sorry, missed the earlier post.

Does the compilation report any error message? Does the running of the release mode exe report any error messages?

It is unlikely to be related to a license limitation as if running an unlicensed version, it will show a watermark but shouldn't crash.

Regards,
Marc Meumann
Steema Support

cormier
Newbie
Newbie
Posts: 3
Joined: Mon Feb 28, 2022 12:00 am

Re: Working *.exe with release configuration in Delphi 10.3

Post by cormier » Fri Mar 25, 2022 11:24 am

Hello Marc,

Thank's for your answer.
The compiler doesn't report any error : 0 warnings and 0 error.

But at the end of compilation (F9) the window of the application doesn't appears and I stay in the IDE.

If I launch the .exe by double clicking on it from window explorer, the windows of the application doesn't appears and I stay in the windows explorer.

I think, the problem is due to my application, because I make a simple application with just one form and one TeeChart Chart, wich works fine in win64 release configuration.

Have any advise on how ti find where is the bug ?

Best regards,

remi cormier

Marc
Site Admin
Site Admin
Posts: 1086
Joined: Thu Oct 16, 2003 4:00 am
Location: Girona
Contact:

Re: Working *.exe with release configuration in Delphi 10.3

Post by Marc » Mon Mar 28, 2022 11:53 am

Hello Remi,

Maybe first check would be that the options that you have set for debug mode, such as search paths, have also been set for release mode. As the two environments pickup separate option sets the cause of the problem may lie there. Mostly, but not exclusively, that would result in a compile error.

Check too, if any connections to a database are being made, that they do actually open for the release compilation.

Regards,
Marc
Steema Support

Post Reply