Installation problem

TeeChart VCL for Borland/CodeGear/Embarcadero RAD Studio, Delphi and C++ Builder.
Post Reply
Metek
Newbie
Newbie
Posts: 3
Joined: Mon Nov 02, 2020 12:00 am

Installation problem

Post by Metek » Tue May 03, 2022 10:26 am

I have tried to update my TeeChart Pro Version with TeeChartVCLFMX-2022.35.
After Installation I get several error messages when I start my Delphi11 Pro (see attached file).
The same problem occurs with TeeChartVCLFMX-2022.34 and effects all older Delphi versions (10.2., 10.3, 10.4) on my system too.
The only solution to continue working is to completely uninstall TeeChart and reinstall version TeeChartVCLFMX-2022.33.
This happens on my desktop PC with Windows 10 Pro as well as on my notebook with Windows 11 Pro.
How can I solve the problem?
Regards
Jürgen
Attachments
Errors.png
Errors.png (416.07 KiB) Viewed 1669 times

Yeray
Site Admin
Site Admin
Posts: 9203
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Installation problem

Post by Yeray » Tue May 03, 2022 11:00 am

Hello Jürgen,

Are those .bpl files in the specified folder? If they aren't, the installation may have failed for some reason. Try a full TeeChart reinstall with high privileges. To do so, you can run the installer "as administrator".

If those .bpls are present and the IDE is failing to find them, please make sure you install TeeChart packages into the IDE with high privileges. To do so, you can run TeeInstall.exe "as administrator".
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Metek
Newbie
Newbie
Posts: 3
Joined: Mon Nov 02, 2020 12:00 am

Re: Installation problem

Post by Metek » Tue May 03, 2022 12:33 pm

Hello Yeray,

this seems to be a permanent problem.
All .bpl files are in the specified folder.
Running TeeInstall.exe as administrator does not solve the problem, even if I start the IDE with administrator rights and try to load the packages manually.

Jürgen

Yeray
Site Admin
Site Admin
Posts: 9203
Joined: Tue Dec 05, 2006 12:00 am
Location: Girona, Catalonia
Contact:

Re: Installation problem

Post by Yeray » Tue May 03, 2022 2:09 pm

Hello,

Do you have all the updates installed in all the IDEs?
- 11.1 (Release 1)
- 10.4 (Release 1)
- 10.3 (Release 3)
- 10.2 (Release 3)
Best Regards,
ImageYeray Alonso
Development & Support
Steema Software
Av. Montilivi 33, 17003 Girona, Catalonia (SP)
Image Image Image Image Image Image Please read our Bug Fixing Policy

Metek
Newbie
Newbie
Posts: 3
Joined: Mon Nov 02, 2020 12:00 am

Re: Installation problem

Post by Metek » Wed May 04, 2022 8:28 am

Hello Yeray,

the problem could be solved by updating from Delphi 11.0 to 11.1.
As a result, the problem no longer occurred with all older Delphi versions (these already had the current updates.)

Thank you

Post Reply