TeeChart Pro 2017 Legend and other issues.

TeeChart for Microsoft Visual Studio.Net, Xamarin Studio (Android, iOS & Forms) & Monodevelop.

TeeChart Pro 2017 Legend and other issues.

Postby KevL » Thu Apr 20, 2017 12:52 pm

I recently upgraded to TeeChartPro 2016 and due to a lot of issues (bugs?) downloaded the update TeeChartPro .Net v4.1.2017.2145. I continue to have a lot of very strange issues. My original project was using TeeChart 2012 I believe which seemed perfectly fine. After installing the new version and finally getting past many issues with licensing. TeeChart.dll versions etc., I was able to compile my project in Studio 2015. The problem is that the charts look and behave very differently. For instance Axis were missing until I installed the 2017 update. Grids were different, Walls were not visible and several other problems. I tried many times to fix this using the designer, but it seems that many items will not "stick", They don't get written to the designer.cs file. Some of these seem to be corrected with 2017, but 1 item in particular still doesn't work. It involves the Legend frame. It is missing completely. I can uncheck the the "Format / Transparent " box and check the "Legend/Format/Frame/Visible" box which will result in the frame being shown in design mode, but once the program is compiled and run, it is again missing. Are these bugs or was my project trashed in some way when I "converted" from 2012 (or it may have 2010) to 2017?


thanks for any help.
Attachments
Capture.JPG
Capture.JPG (17.8 KiB) Viewed 87 times
KevL
Newbie
Newbie
 
Posts: 2
Joined: Fri Jul 08, 2016 12:00 am

Re: TeeChart Pro 2017 Legend and other issues.

Postby KevL » Thu Apr 20, 2017 12:59 pm

Another odd thing is happening. As mentioned before, I have to manually reset the Legend settings in order to see the Frame in the designer. I can't actually see this change however until I change some other property like Position. If I move the Legend / Position property from Right to Top and then back again, the "Frame / Visible" property no takes effect and the frame. This is all futile however because it disappears at runtime unless it place code in the Form.cs file explicitly setting the properties.
KevL
Newbie
Newbie
 
Posts: 2
Joined: Fri Jul 08, 2016 12:00 am

Re: TeeChart Pro 2017 Legend and other issues.

Postby Christopher » Thu Apr 20, 2017 8:19 pm

Hello,

Yes, I'm afraid this appears to be a regression which I've added to our bug-tracking software with id=1846. Many apologies for the inconvenience this has caused - a fix to it will be included into the next maintenance release.

As you have already noted, the workaround is to code this in the code-behind, e.g.

Code: Select all
    Line line;
    private void InitializeChart()
    {
      tChart1.Aspect.View3D = false;

      line = new Line(tChart1.Chart);
      line.FillSampleValues();


      tChart1.Legend.Transparent = false;
      tChart1.Legend.Pen.Visible = true;
      tChart1.Legend.Pen.Color = Color.Red;
    }
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum
Christopher
Advanced
 
Posts: 899
Joined: Fri Nov 15, 2002 12:00 am

Re: TeeChart Pro 2017 Legend and other issues.

Postby KevL » Fri Apr 21, 2017 11:46 am

Thanks for the response. I finally gave up yesterday and reverted back to NET2012. My project compiles, but now I cannot add any new charts. This error message appears when I try to drop a chart on my form.
Attachments
Capture.JPG
Capture.JPG (70.68 KiB) Viewed 70 times
KevL
Newbie
Newbie
 
Posts: 3
Joined: Fri Jul 08, 2016 12:00 am

Re: TeeChart Pro 2017 Legend and other issues.

Postby Christopher » Fri Apr 21, 2017 12:06 pm

KevL wrote:Thanks for the response. I finally gave up yesterday and reverted back to NET2012. My project compiles, but now I cannot add any new charts. This error message appears when I try to drop a chart on my form.


You're welcome.

This operation works as expected here, as can be seen in this screenvideo:
https://www.screencast.com/t/olgo0bEtU6A9

presumably something is going wrong in your particular setup - which version of Visual Studio are you using? Can you give me some simple steps with which I can reliably reproduce your problem here?
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum
Christopher
Advanced
 
Posts: 899
Joined: Fri Nov 15, 2002 12:00 am

Re: TeeChart Pro 2017 Legend and other issues.

Postby KevL » Fri Apr 21, 2017 1:03 pm

I figured it out...

After replacing the 2017 TChart.dll with the old 2012 TChart.dll, the program compiled and ran file since all of the existing charts were originally from that package. I noticed that the charts in the toolbox (that I tried to drop on the form) were still 2016/2017. I deleted those and dropped the TChart.dll from the NET2012 into the toolbox and the new chart was successfully placed on the form.

Please notice that there are other differences (bugs?) between 2012 and 2017. I appears that the border around the chart is off by default. After some messing around I found it was due to the Back "Wall" visibility turned off. It too can be turned on in the designer, but will not get set in the designer.cs file and does not carry over to runtime.
The Axis has similar visibility issues. It looks like many of the "Default" settings are not actually getting set properly. I can enable them in the designer, but they will not show up in the designer.cs file. I assume this is because "default" items do not get written to that file for size reasons. You can see these issues in the attached pictures of default 2012 and 2017 charts.
Attachments
2012 TChart.JPG
2012 TChart.JPG (32.22 KiB) Viewed 66 times
2017 TChart.JPG
2017 TChart.JPG (39.68 KiB) Viewed 66 times
KevL
Newbie
Newbie
 
Posts: 3
Joined: Fri Jul 08, 2016 12:00 am

Re: TeeChart Pro 2017 Legend and other issues.

Postby Christopher » Fri Apr 21, 2017 1:45 pm

Hello,

This is because the default theme has been changed. The 2012 version used Opera, and this can be reset as follows:

Code: Select all
    private void InitializeChart()
    {
      tChart1.CurrentTheme = ThemeType.Opera;
      tChart1.Series.Add(typeof(Line)).FillSampleValues();
    }


which gives me:

TChart636283791178970958.png
TChart636283791178970958.png (34.08 KiB) Viewed 70 times
Best Regards,
Christopher Ireland / Development & Support
Steema Software
Avinguda Montilivi 33, 17003 Girona, Catalonia
Tel: 34 972 218 797
http://www.steema.com
Instructions - How to post in this forum
Christopher
Advanced
 
Posts: 899
Joined: Fri Nov 15, 2002 12:00 am

Re: TeeChart Pro 2017 Legend and other issues.

Postby KevL » Fri Apr 21, 2017 2:40 pm

Wow. Thanks, but I wish I had known that a week ago. It would have saved a huge amount of time trying to make my new 2017 charts match my existing 2012 ones. Why would something like that be changed? Was that change documented anywhere? I didn't see it in the Release.txt file. If it is in there, it is hidden among all the other bug fixes. I feel like major changes like that should be made very clear up front. It wouldn't affect anyone using TeeChart for the first time, but it is a big surprise for those of us who have been using it for many years and are trying to match the look and feel of legacy apps of worse, upgrading in the middle of a project.

Anyway, thanks for the help and quick responses.
KevL
Newbie
Newbie
 
Posts: 3
Joined: Fri Jul 08, 2016 12:00 am


Return to .NET

Who is online

Users browsing this forum: No registered users and 5 guests